Problem with Reaper virtual MIDI

Hi. Problem with Reaper: virtual MIDI keyboard does not sound. The sound level shows fluctuations but there is no sound. All settings are correct. Help me please. What to do?

1 Like

Sorry for the delay in getting back to you on this.

You could try some of the following.

1. Track Monitoring:

  • Check the track’s Record Monitor button. It should be on or set to “Auto” to hear the incoming MIDI being played back through the chosen instrument.
  • Verify the speaker icon on the track isn’t muted. Click or right-click it to ensure monitoring is enabled.

2. MIDI Channel Mismatch:

  • Make sure the virtual keyboard’s MIDI channel matches the instrument’s channel settings. Some keyboards default to specific channels, while instruments might be set to “All.” Check both and adjust if needed.

3. Instrument Selection:

  • Double-check if you’ve loaded a virtual instrument (VSTi) on the track. Reaper’s built-in ReaSynth is a good starting point for testing. Click the FX button on the track and choose an instrument.
  • Sometimes, plugins can get stuck. Try closing and reopening Reaper to refresh the instrument.

4. MIDI Routing:

  • Right-click the track’s “in” button and select “MIDI Input/Virtual MIDI keyboard/All channels.” This ensures the keyboard’s signals reach the track.
  • Verify the track’s “io” button shows the intended “MIDI Hardware Output” for the instrument (e.g., your onboard synth device or VSTi’s internal routing).

5. System Issues:

  • Check if Windows audio settings like speaker volume or mute button aren’t causing silence.
  • Try restarting your computer to clear any temporary glitches.

I hope this helps.

Good luck!